Hi All,

 

In today post I am going to cover Oracle Ebiz applications login issue.

Problem Description:

SSO Environment: Oracle application single sign on server 10.1.4.3 (HTTP, OC4J, and OID), OAM10g, OAS 10g and OIM 9.2 services existing in two nodes and it’s clustered. DB is in RAC mode.

Oracle Ebiz Environment: It’s a multi node environment (12.1.3 unified APPL TOP) with forms, Application listener, web services and (concurrent) Report server existing in two nodes and it’s clustered. DB is in RAC mode.

Two weeks back we have fixed OSSO_OEBS integration issue. For more information click here.

 

We have noticed an error when continuously login into OEBS application more than 5 to 10 times in same browser without close.

 

The ERROR which we have seen is

Error Page
You have encountered an unexpected error. Please contact the System Administrator for assistance.

 

Later we find the root cause for this issue, the users does not have the proper responsibilities and self service session needs to function correctly.

 

When users are not created in the E-Business suite, then the users will not have any responsibilities defined. The recommended solution is currently for you to use the normal eBiz System Administration screens to update specific users with their specific responsibilities, however we have implement a custom process to achieve the same.

 

Following metalink helped us to assign role to user in OEBS:

11i: How To Assign A Default Responsibility To New Users Provisioned From Oid? (Doc ID 431721.1)

 

We have applied following workaround

============

1.            Log into the E-Business suite as the SYSADMIN user and choose Security: User > Define

2.            Query the respective user

3.            Add the “Preferences SSWA” responsibility

4.            Add all other responsibilities required by this user.

5.            Close all browser sessions

6.            Re-test the login

 

We are able to login/logout into Oracle Ebiz applications without errors and warnings with users. Applications are working fine after 5-6 login & logout attempts…

 

I hope this post will help you. Thanks. :)