Upgrade Oracle Applications to 11.5.10.2

Here is quick post on document/notes you should refer to upgrade your Oracle Applications to version 11.5.10.2 

1. Upgrade of Oracle Application to 11.5.10.2 from previous release of 11i (11.5.5 to 11.5.9)  should be done by applying maintenance pack i.e. Patch # 3480000 and few other prereq. & post patch steps. Follow Metalink Note # 316365.1

2. Your application should be on AD minipack I version 2 i.e. 11.AD.I.2 which is available via patch # 4337683 so first apply patch 4337683. (If you are not sure if you already have AD.I.2 or not query AD_BUGS table)

3. If you are planning to merge prereq. patches, NLS patches and other functional patches with 11.5.10.2 (3480000), note that AD.I.2 4337683 should not be merged as it is not possible to merge AD patches.

4. If you are already on 11.5.10 and wish to upgrade to 11.5.10.2, simply apply patch u3460000.drv using adpatch utility (316366.1) – Thanks RajeshManoharan for pointing out typo mistake


Related

Metalink Note #

316365.1 Oracle Applications Release 11.5.10.2 Maintenance Pack Installation Instructions (Use this to upgrade from 11i i.e. 11.5.5,6,7,8,9 to 11.5.10.2)

316366.1 11.5.10 Oracle E-Business Suite Consolidated Update 2 (CU2) (Use this to upgrade from 11.5.10 to 11.5.10.2)

289788.1 Upgrading Oracle Applications  (Use this doc to upgrade to 11.5.10.2 from 10.7 or 11.0.3)

Share This Post with Your Friends over Social Media!

About the Author Atul Kumar

Oracle ACE, Author, Speaker and Founder of K21 Technologies & K21 Academy : Oracle Gold Partner specialising in Design, Implement, and Trainings.

follow me on:

Leave a Comment:

29 comments
PhilWest says November 13, 2007

What is the point of this page?

You could have simply provided a link to the Metalink note. The rest of your text adds nothing more.

The AD.I.2 reference is put of date and there is nothing to guide a budding upgrader through the process.

No timings; pitfalls; workarounds; warnings about AD Delta releases; etc. etc.

Having carried out a number of upgrades to 11.5.10.2, I might point out some of the pitfalls and things to avoid. Whether to upgrade to 10gR2 before or after 11.5.10.2. Whether to migrated to ATM before or afterwards. Issues applying the Maintenance pack, that can easily take 10-20 hours to apply.

Reply
Atul says November 13, 2007

Phil,
I appreciate your feedback and I agree with your point. This post is for DBA’s who want to know start point for 11.5.10.2 upgrade.

Our readers would like to to hear your experiences w.r.t. Upgrade. If you are interested in sharing this with readers please drop me a mail at atul @ onlineAppsDBA.com

Reply
ganeshganta@gmail.com says February 14, 2008

Hi,

Could some one help me on pretty old document finding (i.e. ,10.7 to 11.5.5 or 11.5.8), also could some one tell me, what is the flow migrating 10.7 to 11i (i.e., first 10.7 to 11.5..5)?.

Thanks in advance,

Reply
praveen says February 19, 2008

Hi Atul,
I am planning to Upgrade my appl & db tier from 11.5.9 to 11.5.10.2.when we are applying maintainence pack of 11.5.10.2 i.e patch 3180164(UPDATE APPLPROD.TXT TO ADD NEW PRODUCTS FOR 11.5.10 MAINTENANCE PACK)
This patch is applied before 6 hours,till now it is not completed,at this stage what we need to think about this ..Is the patching process going on internally or is it struck..
The system hanged at this place as showned below..
FAILED: file adsysapp2.sql on worker 1 for product admin username APPLSYS.
Deferred: file adsysapp2.sql on worker 1 for product admin username APPLSYS. (Deferment number 1 for this job)
FAILED: file adgrnp30.sql on worker 2 for product ad username APPLSYS.
Deferred: file adgrnp30.sql on worker 2 for product ad username APPLSYS. (Deferment number 1 for this job)
Assigned: file adsysapp2.sql on worker 1 for product admin username APPLSYS.
Assigned: file adgrnp30.sql on worker 2 for product ad username APPLSYS.

Plz reply me as early as possible.

Reply
praveen says February 19, 2008

Hi Atul,

I am planning to Upgrade my appl & db tier from 11.5.9 to 11.5.10.2.when I am applying maintainence pack of 11.5.10.2 i.e patch 3180164(UPDATE APPLPROD.TXT TO ADD NEW PRODUCTS FOR 11.5.10 MAINTENANCE PACK)
This patch is applied before 6 hours,till now it is not completed,at this stage what we need to think about this ..Is the patching process going on internally or is it struck..
The system hanged at this place as showned below..
FAILED: file adsysapp2.sql on worker 1 for product admin username APPLSYS.
Deferred: file adsysapp2.sql on worker 1 for product admin username APPLSYS. (Deferment number 1 for this job)
FAILED: file adgrnp30.sql on worker 2 for product ad username APPLSYS.
Deferred: file adgrnp30.sql on worker 2 for product ad username APPLSYS. (Deferment number 1 for this job)
Assigned: file adsysapp2.sql on worker 1 for product admin username APPLSYS.
Assigned: file adgrnp30.sql on worker 2 for product ad username APPLSYS.

Plz reply me as early as possible.

Reply
shiva says March 17, 2008

1) Be sure that “applmgr” user runs this “adpatch” session, not root or Oracle user.

Nb: It is possible that the APPS or APPLSYS password was changed and there is a possible
mismatch with the apps privileges ..etc which prevents APPLSYS to lock some objects.

2) – Run adctrl to stop properly the worker which failed.
– Drop the FND_INSTALL_PROCESSES table and the AD_DEFERRED_JOBS table
– Stop Apps and bounce the Database

3) Login as your apps user and source your environment
cd $APPL_TOP
. ./APPSORA.env

env|grep ORACLE_HOME => should point to 8.0.6 Home

Run adpatch again, and DISCARD the previous adpatch session failed, when prompted

Reply
Rafi says March 30, 2008

Hi Phil,Atul,
Iam a Apps DBA with no experince in upgrade…Please as you said about the upgrade….can you please share your experinces…..please can you send me a upgrade document from 11.5.8 to 11.5.10.2 It would be a great help to me.

Thanks
Rafi.(rafi_is_here@yahoo.co.in)

Reply
Atul says March 30, 2008

Rafi,
Follow metalink Note # 316365.1 Oracle Applications Release 11.5.10.2 Maintenance Pack Installation for upgrade from 11.5.8

Reply
Rafi says April 5, 2008

Thanks Atul for the information…If I need help I will ask you.

Reply
praveenjb says April 9, 2008

Hi Atul,

We are in a process of upgrading from 9i to 11g . Our Apps version is 11.5.10.CU2.Can you pls let me know how much donwtime it may take for the whole upgradation process when we do it in a test instance…?

Thanks,
Praveen

Reply
rami says April 14, 2008

hi atul,
can i ask you about the steps that i need to go from 11.5.9 to r12

Reply
Kiran says May 22, 2008

Hi Atul,
We are having custom exe called CMPRINT which prints all the conc program from application. for some reason we are not able to print in out test instance whereas it is working fine in our Development Instance. I had tried to relink the CMPRINT / cmlp exe i got the below error

Starting link of fnd executable ‘CMPRINT’ on Thu May 22 06:28:44 EDT 2008
make: Cannot find a rule to create target
/cft2/app02/ufotappl/fnd/11.5.0/bin/CMPRINT from dependencies.
Stop.
Done with link of fnd executable ‘CMPRINT’ on Thu May 22 06:28:44 EDT 2008

Relink of module “CMPRINT” failed.

========================================
Starting link of fnd executable ‘CMPRINT’ on Thu May 22 06:28:44 EDT 2008
make: Cannot find a rule to create target
/cft2/app02/ufotappl/fnd/11.5.0/bin/CMPRINT from dependencies.
Stop.
Done with link of fnd executable ‘CMPRINT’ on Thu May 22 06:28:44 EDT 2008

Relink of module “CMPRINT” failed.

Reply
Ashish says July 16, 2008

Hi Atul,

Firs of all ,I must say ur posts are really helpful for all the readers.I really appreciate ur effort in keeping up such a huge amount of knowledge.
Second I have a little confusion and would require ur help on that.
Actually we are planning to upgrade our 11.5.10 instance to 11.5.10.2 and db from 9.2.0.8 to 10g rel 2, apart from that forms and reports are to be upgraded from 6i to 10g as well as discoverer from 4i to 10, Please suggest whether the forms and reports 10g are compatible with 11i and if they are not please suggest some metalink doc stating the same.

Thanks in advance
Ashish

Reply
Atul says July 16, 2008

Ashish,
No, 10g forms and reports are not compatible with 11i

Following components of 10g Application Server are certifoed with 11i currently (No Forms & Reports)

##
Oracle Internet Directory, Single Sign-On, Portal, Discoverer, Web Cache, and Oracle Integration (BPEL, ESB, B2B)
##

Check certifiecation Matrix table from metalink using

Certify >> View Certifications by Product >> E-Business Suite >> Submit >> E-Business Suite 11i and Earlier >> Submit >>

Check under “Oracle Application Server 10g ”

As per note
====
Oracle E-Business Suite Release 11i has been certified with Oracle Application Server 10g (10.1.2.0.2) for use of Oracle Internet Directory, Single Sign-On, Portal, Discoverer, Web Cache, and Oracle Integration
====

Now from Platform Selection at bottom select your platform and click submit >> Select 11.5.10 (11i) and click on Submit

In this page under “Application Tier Certifications” you will only see Server as 8.0.6 as only 8.0.6 is supported as Tech stack

Or

Metalink Note 186981.1 Oracle Application Server with Oracle E-Business Suite Release 11i FAQ

Under “Can OracleAS 10g Containers for J2EE be used with 9iAS 1.0.2.2.2?”

OracleAS 10g Containers for J2EE (OC4J) are not yet certified with Oracle E-Business Suite Release 11i. Support for OC4J is included in the E-Business Suite Release 12, as part of its built-in integration with Oracle Application Server 10g.

Note that forms & report in 10g AS use OC4J

Reply
Ashish says July 16, 2008

Hi Atul,

Thanks for the prompt reply, one small question, then if forms and reports 10g are not compatible with 11i what is the max level of upgradation that we can go upto for forms an reports in 11.5.10.2,
is it patchset 18 according to doc 125767.1 or something else.

Thanks & regards
Ashish

Reply
rajeev says July 29, 2008

anyone having experience in merging two oracle instances??
For eg:
Instance 1 having sob1
Instance 2 having sob4, sob5 and sob7.
Now, we want to have a single instance which will have sob1 , sob4,sob5 and sob7.

I am looking for suggestions for high level aproach at the moment. Please reply at rpandey2004@yahoo.com

will appreciate

Reply
rajeshmanoharan says August 18, 2008

Hi Atul,
In the post it’s been mentioned as
4. If you are already on 11.5.10 and wish to upgrade to 11.5.10.2, simply apply patch u3480000.drv using adpatch utility (316366.1)

but for the 11.5.10 to 11.5.10.2 we need to Apply 3460000.drv

Thanks,
Rajesh.

Reply
Atul says August 18, 2008

Rajesh,
Thanks for pointing this out, I’ll update post soon.

Atul

Reply
Maajid says September 10, 2008

3460000 is part of the 3480000

348 supercedes 346. hope that helps

so just applying 3480000 is fine.

Atul, can u confirm? i think i am right

Reply
Maajid says September 10, 2008

sorry to post again so quickly, but what FUNCTIONAL changes are expected from a 11.5.9 to a 11.5.10.2 upgrade?

– Do forms change ie. more Selfservice style forms instead of core apps forms?

– are custom workflows kept as part of the upgrade or do these customisations need to be re-applied afterwards?

Basically, my client, wants to upgrade, due to the necessity, ie, they HAVE to upgrade since Oracle is desupporting 11.5.9, not out of new functions in 11.5.10.

The client wants a upgrade with minimal disruption.. so realisticly, after upgrading do forms change, ie new buttons, or module names change eg. HRMS to HCM… etc etc?

Metalink notes will be useful, but from a functional aspect, I cannot see documents that are relevant.

Reply
Atul says September 10, 2008

Apply 3460000 if you are on 11.5.10.0 and higher and wish to go to 11.5.10.2

Apply 3480000 if you are on release PRIOR to 11.5.10 i.e. 11.5.9, 11.5.8, 11.5.7 ….

Reply
Tasneem says November 17, 2008

Hello Atul,

At the company i’m working for we are actually on oracle release 11.5.10 CU1. We are planning to upgrade to 11.5.10 CU2 since we have been told this is the first step into upgrade to R12 to minimize impact on system.

We have however many customizations done in PL SQL lanaguage for interfaces and reports done in Oracle Reports 6i.

I would be glad if someone can help us determine the impact of these interfaces and reports prior to planning the upgrade so that we can assume how long it might take for the actual upgrade.

Many Thanks
Tasneem

Reply
srihari rao says May 12, 2009

Hi,
Atul how r u ? hw is going?

Recently i have started my database upgradation from 9.2.0.6 to 10.2.0.4 i have done this upgradation.. and now my applications connected to EBS . working fine..

Now my question is … according to metalink note said portal should be upgrade from 3.0.9 to 10g so pl let me know

I just confused is it mendatory to migrade 3.0.9 to 9.0.6 . if so pls let me know how to upgrade with 11i applications & wht is the diffrence between 9i application server & portal ..

Srihari … orkut member…

Reply
Atul Kumar says May 12, 2009

If you are not using Oracle Portal (3.0.9) with 11i then its safe to ignore upgrade of Poratl 3.0.9 to 10g in 11i

312349.1 Remove Oracle Portal 3.0.9 from E-Business Suite 11i

Portal is application which sits on top of application server (9i/1.0.2.2.2 for portal 3.0.9.4 ang 10g AS for 10.1.2 or 10.1.4 Portal)

Reply
Rajesh Jha says June 4, 2009

Atul,

You are doing a great job ! You are a Role Model for me

Rajesh

Reply
hariprathap says August 26, 2009

Hi srihari rao

Can you mention what is the doc id you followed to upgrade the 11i database from 9 to 10g R2

Regards
Hari

Reply
Rajesh says May 25, 2010

11.5.9 -11.5.10.2 upgrade: Applying 8.1.7.4 patch 2376472 to the iAS 1022

We are upgrading Oracle Applications 11.5.9 to 11.5.10.2 following doc 316365.1.At step 4 we are running Technology Stack Validation Utility.
In Technology Stack Validation report it is mentioned

Please apply the 8.1.7.4 patch set 2376472 (32 bit version) to the iAS Oracle Home.

Going through Patch readme, it appears we can apply patch binaries on iAS 1022 home but regarding database portion of patch, how do we handle ?

In the readme of patch set 2376472 do we ignore the database related steps as our Applications database is on 9.2.0.8 ?

Any help is greatly appreciated. Thanks so much

Reply
Atul Kumar says May 25, 2010

@ rajesh,
Yes, you only need to apply it on 1022 iAS Oracle Home . Ignore one for database tier , don’t apply 2376472 on database tier.

Reply
llasanford says February 15, 2011

We are trying to map a time frame for upgrading to CU2 along with the database from 91 to 11g. Can anyone give me a estimate.

thanks
loretta

Reply
Add Your Reply

[index]
[index]
[523.251,1046.50]
[523.251,1046.50]
[523.251,1046.50]
[523.251,1046.50]
[i]
[i]
[index]
[index]
[523.251,1046.50]
[523.251,1046.50]