Oracle Apps R12 Installation Guide

Oracle E-Business Suite Release 12 Installation Guide is now available at Check R12 Installation Guide

Most of the Installation Steps are still same like Oracle Applications 11i . There are few changes and additional options available during Oracle Applications R12 Installation which I’ll cover in my coming posts.

The disk space requirement for R12 is 133 GB for vision database & 28 GB for Application Tier.
If this is fresh Install you need around 45 GB for database & 28 GB for Application Tier.

R12 software CD’s to install are available at http://edelivery.oracle.com/

Stay tuned & register for email Notification to get more updates on Oracle Applications 11i & R12

Share This Post with Your Friends over Social Media!

About the Author Atul Kumar

Oracle ACE, Author, Speaker and Founder of K21 Technologies & K21 Academy : Oracle Gold Partner specialising in Design, Implement, and Trainings.

follow me on:

Leave a Comment:

46 comments
Anonymous says May 14, 2007

hi,
I am looking for an installation document for ebusiness release 12 but I keep getting links to the same pdf.
I am not sure that you have successfully installed release 12, if so why are you not helping beginners by just leaving a step by step installation guide.
thanks

Reply
Atul Kumar says May 15, 2007

If I get time to put step by step I’ll definately put it in my coming post. Do let me know if you are facing any issues in Oracle Apps R 12 installation guide with specific page number and I’ll try to answer your query. For fast response try http://teachMeOracle.com/forum

Reply
Syed Zaheer says January 1, 2008

what is the diffrenece between 11i and r12 installation?

Reply
rajesh says January 2, 2008

hi.,atul

I have done 11i installation on linux es/as 4,then I started my database also but now im getting error from application side while running script

sh adstrtal.sh start apps/apps

Cannot reconnect to gateway

Cause: Application Object Library is unable to reconnect to your gateway ORACLE account after you unsuccessfully attempted to sign-on.

Action: Check that your gateway environment variable is set correctly.
Apache Web Server Listener :httpd ( pid 5518 ) is already running.
Cannot reconnect to gateway

Cause: Application Object Library is unable to reconnect to your gateway ORACLE account after you unsuccessfully attempted to sign-on.

Action: Check that your gateway environment variable is set correctly.
Cannot reconnect to gateway

Cause: Application Object Library is unable to reconnect to your gateway ORACLE account after you unsuccessfully attempted to sign-on.

Action: Check that your gateway environment variable is set correctly.
Apache Web Server Listener :httpd ( pid 5612 ) is already running.
Cannot reconnect to gateway

Cause: Application Object Library is unable to reconnect to your gateway ORACLE account after you unsuccessfully attempted to sign-on.

Action: Check that your gateway environment variable is set correctly.

adapcctl.sh: exiting with status 2

Reply
Nadir says January 21, 2008

Can u please guide me how to install R12 on multi nodes.

Thanks and regards

Reply
Atul Kumar says January 21, 2008

Run installer on database tier first & select component you wish to install on that tier. At services page (which gives you list of services to select – add another node with list of services you wish to start on second node)

Once installed on node1, start installation on node2

Reply
bharadwaz says February 13, 2008

I downloaded Apps 12 from Edelivery.All downloaded files in Zip format.
Shall i unzip all files??? Shall copy all that files into CDs???. Please guide me how can i install that Apps 12.

Regards,
Bharadwaz

Reply
sanjai says March 12, 2008

Hi,
I have installed 11g on windows vista and downloaded Apps 12.
Can you guide me for installing on 11g.

Reply
Gayatri says March 17, 2008

hi
yes I relinked after copying those files.
again I got same adrelink error.
awaiting for reply

Reply
srilatha says March 18, 2008

hai.. Amit & Sarfaraz
For XDOLoader.class you asked me to Apply XDO ROLLUP Patch 4206181.

This has got nearly 10 pre-requiste patches
for every patch the superseed patch is 3480000..

I was in dilama … as I was appling this patch for the error occured while appling 3480000

At last I applied the patch 4206181 without pre-requistes…
I received the message
“adpatch is complete”
I applied even the post-requiste patch ..
I checked the tables ad_bugs and ad_applied_patched…
for above patchno..fine..

******************************************************
1* select bug_id,bug_number from ad_bugs where bug_number=’4206181′
SQL> /

BUG_ID BUG_NUMBER
———- ——————————
109829 4206181
SQL> select patch_name from ad_applied_patches where patch_name=’4206181′;

PATCH_NAME
——————————————————————————–4206181
4206181
*****************************************************************

we resumed the adpatch of 3480000…but we are facing the same issue..

have i gone wrong any where..?
plz guide me ………

awaiting ur reply…
Srilatha

Reply
Srilatha says March 21, 2008

hai.. Amit & Sarfaraz
For XDOLoader.class you asked me to Apply XDO ROLLUP Patch 4206181.

This has got nearly 10 pre-requiste patches
for every patch the superseed patch is 3480000..

I was in dilama … as I was appling this patch for the error occured while appling 3480000

At last I applied the patch 4206181 without pre-requistes…
I received the message
“adpatch is complete”
I applied even the post-requiste patch ..
I checked the tables ad_bugs and ad_applied_patched…
for above patchno..fine..

******************************************************
1* select bug_id,bug_number from ad_bugs where bug_number=’4206181′
SQL> /

BUG_ID BUG_NUMBER
———- ——————————
109829 4206181
SQL> select patch_name from ad_applied_patches where patch_name=’4206181′;

PATCH_NAME
——————————————————————————–4206181
4206181
*****************************************************************

we resumed the adpatch of 3480000…but we are facing the same issue..

have i gone wrong any where..?
plz guide me ………

awaiting ur reply…
Srilatha

Reply
amit says March 22, 2008

Hi Srilatha,

You have to apply the pre-requisites what ever is required. You cannot skip that that will not solve the purpose.

Amit

Reply
Gayatri says March 26, 2008

hi
ya I relinked after copying those files.
again I got same adrelink error.
awaiting ur reply..

Reply
Shabanam A says March 29, 2008

Hi
Iam begginer of apps dba.
iam trying to upgrade apps 11.5.9 (vision demo) to 11.5.10.2. Iam following metalink Doc.ID: 316365.1.
I got struckup at the 7th step “Configure Database for new products and new tablespace requirements”.
While applying patch 3180164….
my workers were hung up.

The details are as follows:
**************************************************
.
.
.
Enter “Yes” below to accept the non-OFA tablespace settings above.
Enter “No” below to abort AutoPatch and create OFA-compliant tablespaces.

Continue with AutoPatch [No] ?

.
.
.
.
.
.
.

If you choose not to drop FND_INSTALL_PROCESSES table, AutoPatch
cannot continue successfully.

Drop FND_INSTALL_PROCESSES table [No] ? YES

FAILED: file adsysapp2.sql on worker 1 for product admin username APPLSYS.
Deferred: file adsysapp2.sql on worker 1 for product admin username APPLSYS. (Deferment number 1 for this job)
FAILED: file adgrnp30.sql on worker 2 for product ad username APPLSYS.
Deferred: file adgrnp30.sql on worker 2 for product ad username APPLSYS. (Deferment number 1 for this job)
Assigned: file adsysapp2.sql on worker 1 for product admin username APPLSYS.
Assigned: file adgrnp30.sql on worker 2 for product ad username APPLSYS.
******************************************************
its not proceeding further.

Awaiting your reply,

Regards,
Shabanam

Reply
amit says March 29, 2008

Hi Shabnam,

Can you check the adworker 1 log file and check the error message.

I suspect there are some locked object in the database so you might have to bounce the database. That we can decide once seeing the error message.

Also check the other workers log file too.

Amit

Reply
Shabanam A says March 31, 2008

hai Amit,

This is WORKER1 log file:-
*****************************************
AD Worker version: 11.5.0
AD Worker started at: Mon Mar 31 2008 11:02:06

APPL_TOP is set to /gcss01/app/oracle/gcssappl

Worker id = 1
Started by: adpatch

NLS_LANG value from the environment is : AMERICAN_AMERICA.WE8ISO8859P1
NLS_LANG value for this AD utility run is : AMERICAN_AMERICA.WE8ISO8859P1

AD Worker error:
Missing file format id in file:

/gcss01/app/oracle/gcssappl/admin/gcss/restart/adpinit.rf9

This version of AD Worker requires a file format id
on the first line of the file.

Connecting to APPLSYS……Connected successfully.

You should check the file
/gcss01/app/oracle/gcssappl/admin/gcss/log/adwork001.log

for errors.
*********************************************************

WORKER STATUS:-

Control
Worker Code Context Filename Status
—— ——– ———————- ——————– ————– 1 Initial AutoPatch R115 adsysapp2.sql Assigned
2 Initial AutoPatch R115 adgrnp30.sql Assigned
3 Initial AutoPatch R115 Wait
4 Initial AutoPatch R115 Wait
**************************************************************

Log file of 3180164:-

There are now 12 jobs remaining (current phase=A0):
0 running, 2 ready to run and 10 waiting.

Assigned: file adsysapp2.sql on worker 1 for product admin username APPLSYS.

Time is: Mon Mar 31 2008 11:02:07

Assigned: file adgrnp30.sql on worker 2 for product ad username APPLSYS.

Time is: Mon Mar 31 2008 11:02:07

FAILED: file adsysapp2.sql on worker 1 for product admin username APPLSYS.

Time is: Mon Mar 31 2008 11:02:07

Deferred: file adsysapp2.sql on worker 1 for product admin username APPLSYS.

Time is: Mon Mar 31 2008 11:02:07
(Deferment number 1 for this job)
FAILED: file adgrnp30.sql on worker 2 for product ad username APPLSYS.

Time is: Mon Mar 31 2008 11:02:07

Deferred: file adgrnp30.sql on worker 2 for product ad username APPLSYS.

Time is: Mon Mar 31 2008 11:02:07
(Deferment number 1 for this job)
Job completed but worker lost connection.
Ignoring the worker 3 failure …

Job completed but worker lost connection.
Ignoring the worker 4 failure …

Assigned: file adsysapp2.sql on worker 1 for product admin username APPLSYS.

Time is: Mon Mar 31 2008 11:02:07

Assigned: file adgrnp30.sql on worker 2 for product ad username APPLSYS.

Time is: Mon Mar 31 2008 11:02:07
**************************************************

waiting ur reply,
shabanam

Reply
amit says March 31, 2008

Hi Shabanam,

Fine in the log file:

——-
AD Worker error:
Missing file format id in file:

/gcss01/app/oracle/gcssappl/admin/gcss/restart/adpinit.rf9

——–

Please check the following action plan and let me know the result.

ACTION PLAN
===========

1. Stop the adpatch session

2. Manually relink both adworker and adpatch as follows
adrelink.sh force=y “AD adpatch”
adrelink.sh force=y “AD adworker”

3. Run adpatch and resume the previous session.

Amit

Reply
shabanam says March 31, 2008

hai Amit,

I have run adrelink for both ad patch & adworker
i got the message adrelink exiting with status 0 for both
and resumed the adpatch but adpatch terminated with the same error message

AD Worker error:
Missing file format id in file:

/gcss01/app/oracle/gcssappl/admin/gcss/restart/adpinit.rf9

awaiting ur reply,
shabanam

Reply
amit says April 1, 2008

Hi Shabnam,

Follow the action plan

-Move all the .rf9 files from the location /gcss01/app/oracle/gcssappl/admin/gcss/restart/ and then reapply the patch afresh.

Amit

Reply
Shabanam says April 1, 2008

hi amit,

I have moved all the .rf9 files from the location /gcss01/app/oracle/gcssappl/admin/gcss/restart/ and then reapplied the patch.
but again it hanged at the same point.

Now the adpatch log file is as follows:
********************************************************
There are now 12 jobs remaining (current phase=A0):
0 running, 2 ready to run and 10 waiting.

Starting worker processes.

Worker process 1 started.

Worker process 2 started.

Worker process 3 started.

Worker process 4 started.

Checking if all jobs have their actual and symbolic arguments in sync….

Done.

Writing jobs to run to restart file.

Reading jobs from FND_INSTALL_PROCESSES table …

Done reading jobs from FND_INSTALL_PROCESSES table …

Telling workers to read ‘todo’ restart file.
Done.

Starting phase 0 (A0): first

There are now 12 jobs remaining (current phase=A0):
0 running, 2 ready to run and 10 waiting.

Assigned: file adsysapp2.sql on worker 1 for product admin username APPLSYS.

Time is: Tue Apr 01 2008 10:36:13

Assigned: file adgrnp30.sql on worker 2 for product ad username APPLSYS.

Time is: Tue Apr 01 2008 10:36:13

Job completed but worker lost connection.
Ignoring the worker 4 failure …

FAILED: file adsysapp2.sql on worker 1 for product admin username APPLSYS.

Time is: Tue Apr 01 2008 10:36:15

Deferred: file adsysapp2.sql on worker 1 for product admin username APPLSYS.

Time is: Tue Apr 01 2008 10:36:15
(Deferment number 1 for this job)
FAILED: file adgrnp30.sql on worker 2 for product ad username APPLSYS.

Time is: Tue Apr 01 2008 10:36:15

Deferred: file adgrnp30.sql on worker 2 for product ad username APPLSYS.

Time is: Tue Apr 01 2008 10:36:15
(Deferment number 1 for this job)

Job completed but worker lost connection.
Ignoring the worker 3 failure …

Assigned: file adsysapp2.sql on worker 1 for product admin username APPLSYS.

Time is: Tue Apr 01 2008 10:36:15

Assigned: file adgrnp30.sql on worker 2 for product ad username APPLSYS.

Time is: Tue Apr 01 2008 10:36:15
******************************************************

The Worker log file adwork001.log is as follows :
*****************************************************
************* Start of AD Worker session *************
AD Worker version: 11.5.0
AD Worker started at: Tue Apr 01 2008 10:36:14

APPL_TOP is set to /gcss01/app/oracle/gcssappl

Worker id = 1
Started by: adpatch

NLS_LANG value from the environment is : AMERICAN_AMERICA.WE8ISO8859P1
NLS_LANG value for this AD utility run is : AMERICAN_AMERICA.WE8ISO8859P1

AD Worker error:
Missing file format id in file:

/gcss01/app/oracle/gcssappl/admin/gcss/restart/adpinit.rf9

This version of AD Worker requires a file format id
on the first line of the file.

Connecting to APPLSYS……Connected successfully.

You should check the file
/gcss01/app/oracle/gcssappl/admin/gcss/log/adwork001.log

for errors.
*****************************************************************************
awaiting your reply,
shabanam

Reply
amit says April 1, 2008

Hi Shabnam,

Are you applying the patch afresh that is not continuing from last seesion or so ?

Please confirm the same

Amit

Reply
Shabanam says April 1, 2008

hi amit,

Ya I have applied freshely

Shabanam

Reply
amit says April 1, 2008

Hi Shabnam

What is the version of AD Minipack you are on ?

Give output of

select bug_number from ad_bugs where bug_number like (‘6502082′,’6502079’);

Amit

Reply
Shabanam says April 1, 2008

hai amit,

select patch_level from fnd_product_installations where application_id=50
SQL> /

PATCH_LEVEL
——————————
11i.AD.I.5

select bug_number from ad_bugs where bug_number in (‘6502082′,’6502079’)
SQL> /

no rows selected

*********************************************

awaiting ur reply
shabanam

Reply
Saurabh says July 11, 2008

Hi Amit,

I hv installed R12 freshly on Oracle Ent. Linux 4. I hv applied all the pre-req patches and rpms and hv followed all the steps about linux setup for R12.

My installation was without any error and went smooth. I’m facing error in post-install checks where the login page and JSP check is failing.

After retrying for sm times, I ran autoconfig and bounced all the applications services. Restarted the rapidwiz. It’s still giving me the same error. Any hints?

-Saurabh

Reply
Atul says July 11, 2008

Saurabh,
Check logs at following place after starting services

$LOG_HOME/ora/10.1.3/opmn
$LOG_HOME/ora/10.1.3/Apache
$LOG_HOME/ora/10.1.3/j2ee/

Atul

Reply
nathawan says August 12, 2008

Hi ,

I have a question , is r12 certified on rhel5.

Thanks ,
Nathawan.

Reply
Atul says August 12, 2008

Officially No, till today (12 Aug 08)

Login to Metalink

Click on “certify tab”
Click on “View Certifications by Product”
Select “E-Business Suite” and click Submit
Select “E-Business Suite Release 12” and click Submit

Select “Linux x86” or “Linux x86-64” and click Submit

You will see RHEL 5 is not in list yet.

It shows certified only on below for 32 bit
-SLES-9
-Red Hat Enterprise AS/ES 4/Oracle VM
-Red Hat Enterprise AS/ES 3
-Oracle Enterprise Linux 4/Oracle VM

and for 64 bit linux
-SLES-9
-Red Hat Enterprise AS/ES 4
-Oracle Enterprise Linux 4

Reply
whose says February 10, 2009

Hi,
On R12, i’m applying a patch and it got applied and updated the ad_applied_patches table..
but now its compiling invalid objects stage (adutlrcmp.sql) for about 22 hours..

Does any one have any what my next step should be?

Reply
Muthu says April 7, 2009

*************************************
[root@amk failed]# rpm cpp-4.1.2-44.el5.i386.rpm -i
warning: cpp-4.1.2-44.el5.i386.rpm: Header V3 DSA signature: NOKEY, key ID e8562897
package cpp-4.1.2-44.el5.i386 is already installed
file /usr/bin/cpp from install of cpp-4.1.2-44.el5.i386 conflicts with file from package cpp-4.1.2-44.el5.i386
file /usr/libexec/gcc/i386-redhat-linux/4.1.1/cc1 from install of cpp-4.1.2-44.el5.i386 conflicts with file from package cpp-4.1.2-44.el5.i386
file /usr/share/man/man1/cpp.1.gz from install of cpp-4.1.2-44.el5.i386 conflicts with file from package cpp-4.1.2-44.el5.i386

*************************************

[root@amk failed]# rpm gcc-4.1.2-14.el5.i386.rpm -i
warning: gcc-4.1.2-14.el5.i386.rpm: Header V3 DSA signature: NOKEY, key ID a7048f8d
error: Failed dependencies:
cpp = 4.1.2-14.el5 is needed by gcc-4.1.2-14.el5.i386
libgomp = 4.1.2-14.el5 is needed by gcc-4.1.2-14.el5.i386
*************************************

[root@amk failed]# rpm gcc-c++-4.1.2-14.el5.i386.rpm -i
warning: gcc-c++-4.1.2-14.el5.i386.rpm: Header V3 DSA signature: NOKEY, key ID a7048f8d
error: Failed dependencies:
gcc = 4.1.2-14.el5 is needed by gcc-c++-4.1.2-14.el5.i386
libstdc++ = 4.1.2-14.el5 is needed by gcc-c++-4.1.2-14.el5.i386
libstdc++-devel = 4.1.2-14.el5 is needed by gcc-c++-4.1.2-14.el5.i386

*************************************

[root@amk failed]# rpm libstdc++-devel-4.1.2-14.el5.i386.rpm -i
warning: libstdc++-devel-4.1.2-14.el5.i386.rpm: Header V3 DSA signature: NOKEY, key ID a7048f8d
error: Failed dependencies:
libstdc++ = 4.1.2-14.el5 is needed by libstdc++-devel-4.1.2-14.el5.i386

*************************************

[root@amk unable to open]# rpm glibc-devel-2.5-12.i386.rpm -i
warning: glibc-devel-2.5-12.i386.rpm: Header V3 DSA signature: NOKEY, key ID 82fd17b2
error: Failed dependencies:
glibc = 2.5-12 is needed by glibc-devel-2.5-12.i386
glibc-headers = 2.5-12 is needed by glibc-devel-2.5-12.i386

*************************************

[root@amk unable to open]# rpm glibc-2.8-3.i386.rpm -i
warning: glibc-2.8-3.i386.rpm: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
glibc-common = 2.8-3 is needed by glibc-2.8-3.i386
glibc > 2.5 conflicts with glibc-common-2.5-34.i386
[root@amk unable to open]# rpm glibc-devel-2.5-12.i386.rpm -i
warning: glibc-devel-2.5-12.i386.rpm: Header V3 DSA signature: NOKEY, key ID 82fd17b2
error: Failed dependencies:
glibc = 2.5-12 is needed by glibc-devel-2.5-12.i386
glibc-headers = 2.5-12 is needed by glibc-devel-2.5-12.i386

******

Reply
Muthu says April 7, 2009

The above message is what I get when I install the RPM prescribed by Oracle thus I am not able to proceed with the R12 installation.
please help me

Reply
asad says October 4, 2009

hi atul

I have tried to install oracle application R12.1.1 on microsoft windows professional with service pack 3 through rapidwiz. after configuration rapidwiz start give error

windows cannot find ‘.\jre\winnt\1.5.0\bin\java’

while in start cd this path is .\jre\winnt\1.5.0\bin\java

please give me the solution of this issue

Reply
asad says October 4, 2009

hi atul

I have tried to install oracle application R12.1.1 on microsoft windows professional with service pack 3 through rapidwiz. after configuration rapidwiz start give error

windows cannot find ‘.\jre\winnt\1.5.0\bin\java’

while in start cd this path is .\jre\winnt\1.6.0\bin\java

please give me the solution of this issue

Reply
Atul Kumar says October 4, 2009

@ Asad,
Please update full path of rapidwiz you are using .

Are you running from staging area or from DVD ?

Reply
asad says October 5, 2009

This is log file. and i also send u the screen shots and path at atul@onlineappsdba.com

config.txt
0
Config File
e:\oracle\PROD\apps\apps_st\appl\admin\asad-b\conf_PROD.txt

[GENERAL]
CONFIGURED_ENVS=PROD
CONFIGURATION_FORMAT=12.0.0
ACTION_TYPE=INSTALLING
NUMBER_OF_HOSTS=2
HOSTNAMES={Server0_asad-b,Server1_asad-b}

[Server0_asad-b]
s_contextname=PROD_asad-b
s_dbSid=PROD
s_dbport=1521
s_platform=Windows NT
s_base_lang=US
s_domainname=aa
s_isDB=YES
s_isAdmin=NO
s_isForms=NO
s_isConc=NO
s_isWeb=NO
s_port_pool=0
s_dbSidLower=prod
s_dbuser=oracle
s_apps_version=12.1.1
s_dbGlnam=PROD
s_dbseed=Fresh Install
s_dbtype=PROD
s_dbcset=US7ASCII
s_base=e:\oracle\PROD
s_db_oh=e:\oracle\PROD\db\tech_st\11.1.0
s_dbhome1=e:\oracle\PROD\db\apps_st\data
s_dbhome2=e:\oracle\PROD\db\apps_st\data
s_dbhome3=e:\oracle\PROD\db\apps_st\data
s_dbhome4=e:\oracle\PROD\db\apps_st\data
s_dbhost=asad-b
s_bits=32
s_db_ons_localport=6300
s_db_ons_remoteport=6400
s_cmanport=1521

[Server1_asad-b]
s_contextname=PROD_asad-b
s_dbSid=PROD
s_dbport=1521
s_platform=Windows NT
s_base_lang=US
s_env_langs=US – American_English
s_defterr=AMERICA
s_domainname=aa
s_dbdomain=aa
s_isDB=NO
s_isAdmin=YES
s_isForms=YES
s_isConc=YES
s_isWeb=YES
s_port_pool=0
s_formsfndtop=e:\oracle\PROD\apps\apps_st\appl\fnd\12.0.0
s_dbSidLower=prod
s_apps_version=12.1.1
s_base=e:\oracle\PROD
s_inst_base=e:\oracle\PROD\inst
s_config_home=e:\oracle\PROD\inst\apps\PROD_asad-b
s_at=e:\oracle\PROD\apps\apps_st\appl
s_at2=e:\oracle\PROD\apps\apps_st\appl
s_at3=e:\oracle\PROD\apps\apps_st\appl
s_at4=e:\oracle\PROD\apps\apps_st\appl
s_tools_oh=e:\oracle\PROD\apps\tech_st\10.1.2
s_weboh_oh=e:\oracle\PROD\apps\tech_st\10.1.3
s_com=e:\oracle\PROD\apps\apps_st\comn
s_javatop=e:\oracle\PROD\apps\apps_st\comn\java\classes
s_pt=e:\oracle\PROD\inst\apps\PROD_asad-b\portal
s_temp=e:\oracle\PROD\inst\apps\PROD_asad-b\temp
s_at_cset=US7ASCII
s_iana_cset=US-ASCII
s_MSDEVdir=C:\MVS\VC
s_MKSdir=C:\cygwin
s_dbhost=asad-b
s_admhost=asad-b
s_formshost=asad-b
s_cphost=asad-b
s_webhost=asad-b
s_root_status=enabled
s_web_entry_status=enabled
s_web_applications_status=enabled
s_batch_status=enabled
s_other_service_group_status=disabled
s_apps_jdbc_connect_descriptor=null
s_rpcport=1626
s_webssl_port=4443
s_ons_localport=6100
s_ons_remoteport=6200
s_ons_requestport=6500
s_webport=8000
s_active_webport=8000
s_formsport=9000
s_metdataport=9100
s_metreqport=9200
s_jtfuf_port=9300
s_mwaPortNo=10200-10205
s_mwaTelnetPortNo=10200,10202,10204
s_mwaDispatcherPort=10800
s_java_object_cache_port=12345
s_oacore_jms_portrange=23000-23004
s_forms_jms_portrange=23500-23504
s_home_jms_portrange=24000-24004
s_oafm_jms_portrange=24500-24504
s_oacore_ajp_portrange=21500-21504
s_forms_ajp_portrange=22000-22004
s_home_ajp_portrange=22500-22504
s_oafm_ajp_portrange=25000-25004
s_oacore_rmi_portrange=20000-20004
s_forms_rmi_portrange=20500-20504
s_home_rmi_portrange=21000-21004
s_oafm_rmi_portrange=25500-25504

PROD
12.0.0
INSTALLING
2
{Server0_asad-b,Server1_asad-b}

PROD_asad-b
PROD
1521
Windows NT
US
aa
YES
NO
NO
NO
NO
0
prod
oracle
12.1.1
PROD
Fresh Install
PROD
US7ASCII
e:\oracle\PROD
e:\oracle\PROD\db\tech_st\11.1.0
e:\oracle\PROD\db\apps_st\data
e:\oracle\PROD\db\apps_st\data
e:\oracle\PROD\db\apps_st\data
e:\oracle\PROD\db\apps_st\data
asad-b
32
6300
6400
1521

PROD_asad-b
PROD
1521
Windows NT
US
US – American_English
AMERICA
aa
aa
NO
YES
YES
YES
YES
0
e:\oracle\PROD\apps\apps_st\appl\fnd\12.0.0
prod
12.1.1
e:\oracle\PROD
e:\oracle\PROD\inst
e:\oracle\PROD\inst\apps\PROD_asad-b
e:\oracle\PROD\apps\apps_st\appl
e:\oracle\PROD\apps\apps_st\appl
e:\oracle\PROD\apps\apps_st\appl
e:\oracle\PROD\apps\apps_st\appl
e:\oracle\PROD\apps\tech_st\10.1.2
e:\oracle\PROD\apps\tech_st\10.1.3
e:\oracle\PROD\apps\apps_st\comn
e:\oracle\PROD\apps\apps_st\comn\java\classes
e:\oracle\PROD\inst\apps\PROD_asad-b\portal
e:\oracle\PROD\inst\apps\PROD_asad-b\temp
US7ASCII
US-ASCII
C:\MVS\VC
C:\cygwin
asad-b
asad-b
asad-b
asad-b
asad-b
enabled
enabled
enabled
enabled
disabled
null
1626
4443
6100
6200
6500
8000
8000
9000
9100
9200
9300
10200-10205
10200,10202,10204
10800
12345
23000-23004
23500-23504
24000-24004
24500-24504
21500-21504
22000-22004
22500-22504
25000-25004
20000-20004
20500-20504
21000-21004
25500-25504

Reply
Atul Kumar says October 6, 2009

@ Asad,
Which version of windows (XP , Vista or Server) is this ?

Create staging area and download and create jre 1.5.0 in same folder (in which installer is expecting and then try )

Reply
asad says October 6, 2009

I am using Windows Xp Professional version 2002 service pack 3.

I have done this but installer could not run

Reply
Sunil says October 16, 2009

Hi Atul,
I read your posts and really appreciate your efforts for the community.

I have successfully installed R12.1.1 vision instance on Oracle Enterprise Linux 5.4. Installed for practice, I am not a DBA.

System config is Desktop with P4 processor, 3 GB RAM, 320 GB HDD.

Installation went smooth except the last step, post installation checks. I later realized that it is taking time to start the services, hence, I have increased the timeout in the config and it went fine.

I am running the following scripts to start the database & applications:

#Start the database
cd /home/sunil/oracle/db/tech_st/11.1.0/appsutil/scripts/R12VIS_sunil-linux
./addbctl.sh start apps/apps

#Start Listner
cd /home/sunil/oracle/db/tech_st/11.1.0/appsutil/scripts/R12VIS_sunil-linux

./addlnctl.sh start R12VIS

##### Start APPS ############

cd /home/sunil/oracle/inst/apps/R12VIS_sunil-linux/admin/scripts

./adstrtal.sh apps/apps

When I run these commands, all commands are executed successfully within couple of minutes.

When I try to launch apps from the browser, here is what is happening:
1. It shows “Waiting for xxx host…” message in the browser status bar for around 10 minutes
2. I try the same URL again, it takes several minutes, and shows “500 Internal Server Error”.
3. After another 10 minutes I try the same URL,
then it progresses and displays the login page in few minutes.
4. After I enter login credentials, it again takes a while to show the responsibilities.
5. From that point onwards, system performance is faster.

All through step 1-3, I don’t see much of activity happening on system. Can you please help me how to troubleshoot this issue?

Thanks & Regards,
Sunil

Reply
Atul Kumar says October 18, 2009

Sunil,
I faced similar issue with our VMware image and realised that when you start concurrent manager (part of adstrtal.sh script) it eats up lot of resources and connection to database , hence you see internal server error (OC4J waiting on database for reply)

It seems either your databhase is on slow (I/O) disk or you don’t have enough RAM

To fix this issue after start of services (concurrent manager) wait for some time (15-30 minutes) and then try connection or shutdown concurrent manager

from application tier
cd $ADMIN_SCRIPTS_HOME
./adcmctl.sh stop apps/apps

Reply
sg_mac says February 12, 2010

Dear Atul,

I have installed Oracle Apps 11.5.10 in windows xp sucessfully . I do have a question, since i am familiar with Unix environment so i am getting confused to execute the setting in windows, Can you please guide.

1. How should i run dot profile in windows , so i need to create a batch file and do the same ..and what will be the contents in the batch file.

2. For getting into Appenv and Dbenv how should i execute in windows environment ..

I am familiar with Unix ,Can you kindly guide for Windows xp.

Reply
Atul Kumar says February 15, 2010

@ sg_mac
I am hoping cygwin or mks toolkit on windows should give you commands similar to Unix on Windows.

I am not an expert in windows but

an you not run (source) environment variable on windows similar to Unix (after cygwin or mks which is prereq for apps installation on windows) ?

Reply
sg_mac says February 15, 2010

Dear Atul ,

Thanks for your reply , however i got the solution, that to run in windows to use .cmd , so my problem got solved.

But i do have a query my Apps on Windows is 11i and my database is 9i , i want to upgrade only my database to 10g. can you please give me step by step information , what need to be done. For Windows environment.

Thanks in Advance

Sumit Ghosh

Reply
Atul Kumar says February 17, 2010

@ Sumit,
Use Oracle My Support (metalink) Note “362203.1 Oracle Applications Release 11i with Oracle 10g Release 2 ” to upgrade database to 10g in 11i

Reply
Abhishek says May 17, 2010

Hi Atul,

I had downloaded and installed Oracle Apps (on VMWare) 12.1.1 as you explained.
Initially there was directory issue which got resolved by creating directory n giving it permission.

Post install there was error in JSP, HTTP n all. The Database was created properly.

There was some SEDenial during install as well.

I finished installation even with above errors. When i was starting Database, I got the SEDenial again. I did the steps to remove this error as suggested by OS pop up.

Database finally restarted.

Now while starting application, first of all i got error while setting environment, that some dev*.env file not found. Later i found out that there is some issue and application was not starting. The environment variables are not getting set. Somewhere %s_base% value is not set as when i do ‘echo $APPL_TOP’, it as well show %s_base% at the start instead of complete path.

Please suggest what needs to be done.

Note: I had not installed any other softwares like gcc etc. I directly installed Oracle Enterprise Linux and then Oracle 12.1.1 on it.

Reply
Rajath Reddy says November 9, 2010

Hi Atul,
I installed R12 on OEL5. My machine Config is Intel I3,2GB RAM. 500 GB HDD. Installed VMware on XP. Installation went well without any errors.
Psot install check was 100% successfull. But when I log in as sysadmin and tried to open a Form (System Administrator/User/Define) windows open up and a form saying FRM 92101 : Unable to start the Form server. Reason could be an Invalid configuration. Db is up and running. starting apps without errors.exiting with status 0.
Pls help.

Reply
John Doe says March 25, 2011

You say the prerequisite OS packages are given in the installation manual. This is not the case.

Reply
Add Your Reply