Upgrade Oracle Applications to 12.0.4

Oracle Applications Release 12 update 4 (12.0.4) is available now.  This post covers top level steps for upgrading Oracle Applications R12 (12.0.0, 12.0.1, 12.0.2, 12.0.3) to latest patchset i.e. 12.0.4

Key Points for Upgrade to 12.0.4
1. You can upgrade to 12.0.4 directly from following releases 11.5.8, 11.5.9 (Base, Update1 and Update2), 11.5.10 (Base, Update1 and Upadte2), R 12 (Base, 12.0.1, 12.0.2, 12.0.3)

2. Patch Number for 12.0.4 is 6435000  (Apply this patch if you are upgrading from R12 i.e. 12.0.0, 12.0.1, 12.0.2 or 12.0.3)

3. If you are upgrading from R12 (12.0.1, 12.0.2, 12.0.3), first apply R12.AD.A.DELTA.4 (6510214).

4. After applying 12.0.4 patch (6435000) apply consolidated online help patch (6400100) and apply other functional patches (depending on product you are using) as per Metalink Note # 465776.1 and read me of patch 6435000

5. After application of 12.0.4 patch bring database context to 12.0.4 code
–Build appsutil.zip on application tier
–Copy appsutil.zip to dataabse tier
–Run Autoconfig on database tier

6. 12.0.4 is also called as Release 12 Update 4 or RUP4 and cumulative patchset (include 12.0.1, 12.0.2, 12.0.3)

Related Docs/Metalink Notes
556312.1  Now Available: Oracle E-Business Suite Release 12.0.4
549389.1  Oracle Applications Release Notes, Release 12.0.4
465776.1  Oracle E-Business Suite 12.0.4 Release Update Pack Readme
402310.1  Oracle Applications Installation and Upgrade Notes Release 12 (12.0.4) for Linux (32-bit)
Read Me of Patch 6400100
Read Me of Patch 6510214

Step by Step Upgrade of Oracle Applications R12 to 12.0.4; including issues encountered coming soon !!!

Share This Post with Your Friends over Social Media!

About the Author Atul Kumar

Oracle ACE, Author, Speaker and Founder of K21 Technologies & K21 Academy : Oracle Gold Partner specialising in Design, Implement, and Trainings.

follow me on:

Leave a Comment:

14 comments
SUBIR PAUL says May 24, 2008

After installing the 12.0.4,when I going to run adautonfig.cmd in both DB tier and APPL tier it is giving following errors:
################3
E:\oracle12\VIS12\inst\apps\VIS12_ctsincalsxac\admin\scripts>adautocfg.cmd
.
Starting up AutoConfig engine…
.
Sat 05/24/2008
06:31 PM
Enter the APPS user password:*****

The log file for this session is located at: E:\oracle12\VIS12\inst\apps\VIS12_ctsincalsxac\admin\log52418
31\adconfig.log

AutoConfig is configuring the Applications environment…

AutoConfig will consider the custom templates if present.
Using CONFIG_HOME location : E:\oracle12\VIS12\inst\apps\VIS12_ctsincalsxac
Classpath : E:\oracle12\VIS12\apps\apps_st\comn\java\lib\appsborg2.zip;E:\oracle12
\VIS12\apps\apps_st\comn\java\classes

backdir=E:\oracle12\VIS12\inst\apps\VIS12_ctsincalsxac\admin\out5241831 – AC-30202: Unrecognized action sp
ecified. Exiting.

Error returned from java. Context Value Management was aborted
ERROR: Context Value Management Failed.
Terminate.

The logfile for this session is located at:
E:\oracle12\VIS12\inst\apps\VIS12_ctsincalsxac\admin\log5241831\adconfig.log
Completed execution of AutoConfig

Regards,
Subir

Reply
Amit says May 26, 2008

Hey Subir ,

Check the version of CtxValueMgt.class at

$AD_TOP/java/oracle/apps/ad/context and
$JAVA_TOP/oracle/apps/ad/context

Also at which ADX patch level you are ?

Apply the latest ADX patch and rerun autoconfig

Let me know if this solve your issue

Regards
Amit

Reply
Jas says August 26, 2008

Hi , RUP4 is now compatible with 10.2.0.4 database
thnx
jas

Reply
Tiru says December 24, 2008

Hi Amit,

I am getting below error wile running autoconfig on Apps Tier(Web & forms) after 11.5.10.2 – 3480000 maintenance patch on 2003 Box

Starting AutoConfig at Wed Dec 24 17:26:50 2008
Using adconfig.pl version 115.81

Classpath : e:\oracle\efincomn\util\jre\1.1.8\lib\rt.jar;e:\o
racle\efincomn\java\appsborg.zip;e:\oracle\efincomn\java

================================
===========================================
Starting Utility to Report Version Conflicts at Wed Dec 24 17:26:55 GMT 2008
Using VersionConflictListGenerator.java version 115.2

All driver files processed.

No version conflict encountered.
============================================
===============================
ERROR: Context Value Management Failed.
Terminate.

The logfile for this session is located at:
e:\oracle\efinappl\admin\EFIN_yforaodevapps\log\12241726\adconfig.log

———–

As said I checked CtxValueMgt.class at

%AD_TOP%/java/oracle/apps/ad/context and
%JAVA_TOP%/oracle/apps/ad/context

both are of different size

under AD_TOP CtxValueMgt.class 27,379
under JAVA_TOP CtxValueMgt.class 26,187

Thanks

Reply
Atul Kumar says December 29, 2008

Tiru,
Whats in adconfig.log ?

Reply
Tiru says December 30, 2008

Hi Atul

adconfig.log has same error

===adconfig.log– contents====

Starting AutoConfig at Tue Dec 30 13:30:02 2008
Using adconfig.pl version 115.81

Classpath : e:\oracle\odevcomn\util\jre\1.1.8\lib\rt.jar;e:\oracle\odevcomn\java\appsborg.zip;e:\oracle\odevcomn\java

===========================================================================
Starting Utility to Report Version Conflicts at Tue Dec 30 13:30:06 GMT 2008
Using VersionConflictListGenerator.java version 115.2

All driver files processed.

No version conflict encountered.
===========================================================================
ERROR: Context Value Management Failed.
Terminate.

The logfile for this session is located at:
e:\oracle\odevappl\admin\ODEV_yforaodevapps\log\12301330\adconfig.log

==========

I reran 348000 patch and I am getting same msg.

Thanks

Reply
Atul Kumar says December 30, 2008

Try this

Remove the classes LdxLibThin.class & LnxLibThin.class from $JAVA_TOP/oracle/sql

Check 473157.1 Autoconfig error ‘Context Value Management Failed’

Reply
Tiru says December 31, 2008

Thanks Atul,

I have resolved the issue by re-applying “6372396” on top of 3480000, the issue is with the 3480000 which copies below version
%AD_TOP%/java/oracle/apps/ad/context/CtxValueMgt.class Version 115.36

which is different from file under
%JAVA_TOP%/oracle/apps/ad/context CtxValueMgt.class Version 115.08

applying 6372396 will sync files in both AD_TOP and JAVA_TOP.

Reply
Mohan Raju says February 4, 2009

Hi Atul ,

As part of R12 upgradation installing the file system using the rapidwiz.

Following is the dir structure i used.

APPL_TOP = /ohrdshr/appohrdba/apps_st/ohrdbaappl
COMMON_TOP = /ohrdshr/appohrdba/apps_st/ohrdbacomn
INST_TOP = /ohrdshr/appohrdba/apps_st/inst

$TOOLS_HOME = /ohrdshr/oracle/product/tech_st/ohrdbaora/10.1.2
IAS_ORACLE_HOME = /ohrdshr/oracle/product/tech_st/ohrdbaora/10.1.3

Rapidwiz install on application node failed as Upgrade fail with following error at finale validation stage

————————————————
System Check Details
———————
Upgrade File – Check that Rapid Install has delivered and instantiated upgrade files

Upgrade File
RW-50016: Error: – APPL_TOP environment file was not created:
File = /ohrdshr/appohrdba/apps_st/ohrdbaappl/OHRDBA_corpt031v.env
ADOVARS environment file passes instantiated variables test:
File = /ohrdshr/appohrdba/apps_st/ohrdbaappl/admin/adovars.env
APPSCONFIG passes instantiated variables test:
File= /ohrdshr/appohrdba/apps_st/ohrdbaappl/admin/adconfig.txt

————————————————

in the adconfig.log i see below error

————————————————
Starting AutoConfig at Tue Feb 3 14:41:17 2009
Using adconfig.pl version 120.16

Script execution phase specified: INSTE8_SETUP
Classpath : /ohrdshr/appohrdba/apps_st/ohrdbacomn/java/lib/appsborg2.zip:/ohrdshr/appohrdba/apps_st/
comn/java/classes

ERROR: Version Conflicts utility failed.
Terminate.

The logfile for this session is located at: /ohrdshr/appohrdba/apps_st/inst/apps/OHRDBA_corpt031v/admin/log/02031441/adconfig.
log
Starting AutoConfig at Tue Feb 3 14:41:21 2009
Using adconfig.pl version 120.16

Classpath : /ohrdshr/appohrdba/apps_st/ohrdbacomn/java/lib/appsborg2.zip:/ohrdshr/appohrdba/apps_st/
comn/java/classes

ERROR: Version Conflicts utility failed.
Terminate.

The logfile for this session is located at: /ohrdshr/appohrdba/apps_st/inst/apps/OHRDBA_corpt031v/admin/log/02031441/adconfig.
log
————————————————-

Did anybody faced this issue before.

Thanks,
Mohan

Reply
vinay says March 16, 2009

Hi Atul,

After upgrading from R 11.5.0.2 to R 12.0.4, Create Accounting concurrent program of AP is not working fine whereas i don’t have accounting problem in AR.
When i try to run Validate Application Accounting Definitions concurrent program, iam unable to select Payables in Application parameter.
Request your help to resolve this issue.

Thanks
Vinay

Reply
Atul Kumar says March 16, 2009

Check these notes

551504.1 How to troubleshoot the R12 Create Accounting process
461165.1 R12 Unable to Account for Upgraded Invoices/Payments
567430.1 – Create Accounting Errors with Message 95359 for Payment Cancellation Events Upgraded to R12
735637.1 Create Accounting Is Not Picking Up Additions And Retirements From 11i

Reply
vinay says March 18, 2009

Hi Atul,

I couldn’t find resolution for my issue in the above notes.

We have upgraded R 11.5.0.2 Vision instance to R 12.0.4
we have following issues in R 12.0.4 instance.
1 We are unable to do create accounting for AP in R 12.
I found some SLA setups are missing.
Should i have to do those SLA setups manually or should i apply any patch for SLA setups?
2 In OM, Pick release process is throwing Sales Order to backorder even enough Onhand stock is available in inventory.
These two processes have worked fine in R 11.5.0.2 ( prior to upgrade)

Reply
nisarwangde says December 19, 2009

Hi Atul,

We are currently on R 12.0.4.

Is it possible to have oracle financials on R 12.0.6 without other modules upgraded.

Reply
Add Your Reply