.

I mentioned about availability of Oracle Identity & Access Management version 11gR2 PS2 (11.1.2.2).

This post covers changes in installation from previous version of these components (OIM, OAM, OAAM, OES, OPAM) i.e.

a) 11gR1 – 11.1.1.3, 11.1.1.5, 11.1.1.7
b) 11gR2 – 11.1.2.0, 11.1.2.1

 

Installation steps are more or less same as 11gR1 or 11gR2 (including PS1) with following additional steps

1. You must upgrade the OPSS schema (XXX_OPSS) from 11.1.1.7.0 to 11.1.1.7.2

Note: When you create OPSS schema using 11.1.2.2 RCU, OPSS schema version is 11.1.1.7.0 . You must upgrade OPSS schema from 11.1.1.7.0 to 11.1.1.7.2 using Patch Set Assistant (PSA) 

2. You must configure security store to database (configureSecurityStore.py)

Note 1: By default security store (credential & policy store) is in XML file and this step migrates it to database in OPSS schema.

Note 2: This step is also required in 11gR2 and PS1 (11.1.2.0 & 11.1.2.1)

Note 3: In 11gR1 (11.1.1.3, 11.1.1.5) policy store could be set to either in XML, OID, or Oracle Database .

 

3. You can deploy IAM in 11gR2 PS 2 using IAM Lifecycle Tools (idmlcm) More information here (Deploying IAM using IDMLCM is optional)

Note: Deployment of IAM using IAM Lifecycle Management Tool (idmlcm) is mainly for Oracle Fusion Applications

 

High Level installation Steps of IAM 11gR2 PS2 (11.1.2.2)

  • Install JDK 1.6
  • Install WebLogic 10.3.6
  • Install IAM 11.1.2.2
  • Create Schema in database using RCU 11.1.2.2
  • Install SOA 11.1.1.7 (Only if you are installing OIM)
  • Configure WebLogic Domain and select components (OIM, OAM, OES, OPAM, OAAM )
  • Upgrade OPSS
  • Configure Database Security Store
  • Configure OIM (If you are planning to use OIM)
  • Start Services

 

Here is installation guides for IAM 11gR2 PS2 (11.1.2.2)